Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2015-06-14 22:28:11 +0000
committerStijn Buys <ingar@osirion.org>2015-06-14 22:28:11 +0000
commit2e84c896830b421bce3dee86be197c553cf89928 (patch)
tree9fafdb0879731009f62d0a9f1464c1947c87c158 /configure.ac
parentf8ac713c0c0015b51bff37c92955cd6a38cda83d (diff)
Reverted the previous change and renamde the --enable-static-libc configure option to --enable-static-stdlib.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 3 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index ffaafd8..f07db68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,24 +170,10 @@ dnl ----------------------------------------------------------------
dnl static libc
dnl
-AC_ARG_ENABLE(static_libc,
- AC_HELP_STRING([--enable-static-libc], [staticly link with libc]),
+AC_ARG_ENABLE(static_stdlib,
+ AC_HELP_STRING([--enable-static-stdlib], [staticly link with libgcc and libstdc++]),
AC_MSG_RESULT(yes)
- STATIC_LDADD="$STATIC_LDADD -static-libgcc",
- AC_MSG_RESULT(no)
- STATIC_LDADD=""
-)
-
-AC_SUBST(STATIC_LDADD)
-
-dnl ----------------------------------------------------------------
-dnl static libstdc++
-dnl
-
-AC_ARG_ENABLE(static_libc,
- AC_HELP_STRING([--enable-static-libstdc++], [staticly link with libstdc++]),
- AC_MSG_RESULT(yes)
- STATIC_LDADD="$STATIC_LDADD -static-libstdc++",
+ STATIC_LDADD="-static-libgcc -static-libstdc++",
AC_MSG_RESULT(no)
STATIC_LDADD=""
)