Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-03-29 00:20:43 +0000
committerStijn Buys <ingar@osirion.org>2008-03-29 00:20:43 +0000
commit53007b7b524a3cfc8ac426d5809231ef9d48fe18 (patch)
treecd8e291752a40d0033e160fbdd5eab1c15f11b77 /src/Makefile.am
parent59248fb9e96ac159886f5bbb5cf7e2bb2755c930 (diff)
win32 icons
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bdb46ee..504afb6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,20 +1,27 @@
# set the include path found by configure
AM_CPPFLAGS = $(DEBUG_CFLAGS) $(WARN_CFLAGS) $(all_includes)
-SUBDIRS = math sys filesystem core server render client game
+SUFFIXES = .rc
+.rc.o:
+ windres $< -o $@
+SUBDIRS = math sys filesystem core server render client game
noinst_HEADERS = config.h
bin_PROGRAMS = osiriond osirion
# dedicated server
osiriond_SOURCES = osiriond.cc
-osiriond_LDADD = $(top_builddir)/src/game/libgame.la \
+EXTRA_osiriond_SOURCES = osiriond-res.rc
+osiriond_DEPENDENCIES = $(ICON_SERVER)
+osiriond_LDADD = $(ICON_SERVER) $(top_builddir)/src/game/libgame.la \
$(top_builddir)/src/core/libcore.la $(top_builddir)/src/server/libserver.la \
$(HOST_LIBS)
# client
osirion_SOURCES = osirion.cc
+EXTRA_osirion_SOURCES = osirion-res.rc
+osirion_DEPENDENCIES = $(ICON_CLIENT)
osirion_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS) $(GLUT_CFLAGS)
-osirion_LDADD = $(top_builddir)/src/game/libgame.la \
+osirion_LDADD = $(ICON_CLIENT) $(top_builddir)/src/game/libgame.la \
$(top_builddir)/src/core/libcore.la $(top_builddir)/src/client/libclient.la \
$(HOST_LIBS) $(GL_LIBS)
osirion_LDFLAGS = $(LIBSDL_LIBS)