Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-06-08 18:39:17 +0000
committerStijn Buys <ingar@osirion.org>2008-06-08 18:39:17 +0000
commit70fc89d31b81a0cc49fc4b8daf527dd187544d9e (patch)
tree5f96e28da7cf095947a8f1c612e9cacb09f2ab41 /src/Makefile.am
parent513bfb8d9cf3c246dd15cf67b8a5ff9c7a6f9afe (diff)
disable client prediction by default, add --without-client option to configure
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 37e1b2e..9c55179 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,10 +4,20 @@ SUFFIXES = .rc
.rc.o:
windres $< -o $@
-SUBDIRS = sys math auxiliary filesystem model core server audio render client \
- game
+if BUILD_CLIENT
+ MAYBE_CLIENT_SUBDIRS = audio render client
+ MAYBE_CLIENT_PROGRAMS = osirion
+endif
+
+SUBDIRS = sys math auxiliary filesystem model core server $(MAYBE_CLIENT_SUBDIRS) game
+
noinst_HEADERS = config.h
+
+if BUILD_CLIENT
bin_PROGRAMS = osiriond osirion
+else
+bin_PROGRAMS = osiriond
+endif
# dedicated server
osiriond_SOURCES = osiriond.cc