Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2010-11-16 19:26:53 +0000
committerStijn Buys <ingar@osirion.org>2010-11-16 19:26:53 +0000
commit2daac503a3a2f149f883db7c30199ebbb1f00c7f (patch)
tree6f53bf73d376b6458b173b8d25fd8b420a47911f /src/client/Makefile.am
parent2056ffa670f6d86ad7c9736ebf2886df3753dbbe (diff)
cleaned up autoconf/automake project files, this should solve build order and dependency issues
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am25
1 files changed, 18 insertions, 7 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index 8edef84..d9ca552 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -7,6 +7,12 @@ else
noinst_LTLIBRARIES = libclient.la
endif
+
+noinst_HEADERS = action.h chat.h client.h clientext.h hud.h entitymenu.h \
+ input.h inventorylistview.h inventory.h joystick.h key.h keyboard.h map.h notifications.h soundext.h \
+ targets.h video.h infowidget.h playerview.h worldview.h trademenu.h buymenu.h \
+ targeticonbutton.h
+
libclient_la_SOURCES = action.cc buymenu.cc chat.cc client.cc clientext.cc \
entitymenu.cc hud.cc infowidget.cc input.cc inventorylistview.cc inventory.cc joystick.cc key.cc \
keyboard.cc map.cc notifications.cc playerview.cc soundext.cc targeticonbutton.cc \
@@ -14,12 +20,17 @@ libclient_la_SOURCES = action.cc buymenu.cc chat.cc client.cc clientext.cc \
libclient_la_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
-libclient_la_LDFLAGS = -avoid-version -no-undefined $(GL_LIBS) $(LIBSDL_LIBS)
+libclient_la_DEPENDENCIES = \
+ $(top_builddir)/src/auxiliary/libauxiliary.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/sys/libsys.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la \
+ $(top_builddir)/src/model/libmodel.la \
+ $(top_builddir)/src/core/libcore.la \
+ $(top_builddir)/src/audio/libaudio.la \
+ $(top_builddir)/src/render/librender.la \
+ $(top_builddir)/src/ui/libui.la
-noinst_HEADERS = action.h chat.h client.h clientext.h hud.h entitymenu.h \
- input.h inventorylistview.h inventory.h joystick.h key.h keyboard.h map.h notifications.h soundext.h \
- targets.h video.h infowidget.h playerview.h worldview.h trademenu.h buymenu.h \
- targeticonbutton.h
+libclient_la_LIBADD =
-libclient_la_LIBADD = $(top_builddir)/src/core/libcore.la $(top_builddir)/src/audio/libaudio.la \
- $(top_builddir)/src/render/librender.la $(top_builddir)/src/ui/libui.la
+libclient_la_LDFLAGS = -avoid-version -no-undefined