Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2014-12-07 23:27:31 +0000
committerStijn Buys <ingar@osirion.org>2014-12-07 23:27:31 +0000
commit493e4317e19725e2de2d51753e5c1906bf9c64ba (patch)
treec46831d6d661a79b5da6580d4472d39a615fedea /src/client/Makefile.am
parent941c64546ca22b87a9153d36e9e3fe59c18abafe (diff)
Implemented messageboxes and the ability for the game module to send them to remote clients,
send a messagebox if the player's ship is destroyed, this fixes having to press the respawn button twice. added messageboxes on network connection failures.
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index f6d447d..5577879 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -34,6 +34,7 @@ noinst_HEADERS = \
mainwindow.h \
mapwidget.h \
mapwindow.h \
+ messagebox.h \
notifications.h \
reputationwindow.h \
savegamemenu.h \
@@ -70,6 +71,7 @@ libclient_la_SOURCES = \
mainwindow.cc \
mapwidget.cc \
mapwindow.cc \
+ messagebox.cc \
notifications.cc \
reputationwindow.cc \
savegamemenu.cc \