Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2009-01-27 18:53:24 +0000
committerStijn Buys <ingar@osirion.org>2009-01-27 18:53:24 +0000
commit9c2d1a1c867bbd7eea083dbc03c0acf1edace8c2 (patch)
tree51b0f6e52d4dc368fc8358aa86cca395b6d2506b /src/client/Makefile.am
parent76a49efdf62a53a54e2deeb559422f11c1e955dd (diff)
moves docking menus from ui to client,
allow map and chat window while docked
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index d617b52..e5afbb7 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -7,9 +7,9 @@ else
noinst_LTLIBRARIES = libclient.la
endif
-libclient_la_SOURCES = action.cc chat.cc client.cc clientext.cc hud.cc \
- infowidget.cc input.cc joystick.cc key.cc keyboard.cc map.cc notifications.cc \
- playerview.cc soundext.cc targets.cc video.cc worldview.cc
+libclient_la_SOURCES = action.cc chat.cc client.cc clientext.cc entitymenu.cc \
+ hud.cc infowidget.cc input.cc joystick.cc key.cc keyboard.cc map.cc \
+ notifications.cc playerview.cc soundext.cc targets.cc video.cc worldview.cc
libclient_la_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
libclient_la_LDFLAGS = -avoid-version -no-undefined $(GL_LIBS) $(LIBSDL_LIBS)
@@ -19,3 +19,4 @@ noinst_HEADERS = action.h chat.h client.h clientext.h hud.h input.h joystick.h \
libclient_la_LIBADD = $(top_builddir)/src/core/libcore.la $(top_builddir)/src/audio/libaudio.la \
$(top_builddir)/src/render/librender.la $(top_builddir)/src/ui/libui.la
+_SOURCES = entitymenu.h