Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1a6aee7..3c6db7a 100644
--- a/configure.in
+++ b/configure.in
@@ -193,6 +193,15 @@ else
AC_SUBST(GL_LIBS)
AC_SUBST(GL_CFLAGS)
+ AC_CHECK_HEADER(png.h,
+ HAVE_OPENGL=yes
+ AC_DEFINE(HAVE_PNG, 1, [Define this if you have libpng]),
+ AC_MSG_WARN([libpng include file png.h not found])
+ )
+
+ LIBPNG_LIBS="-lpng"
+ AC_SUBST(LIBPNG_LIBS)
+
AC_CHECK_HEADER(AL/al.h,
HAVE_OPENGL=yes
AC_DEFINE(HAVE_OPENAL, 1, [Define this if you have OpenAL]),