Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@telenet.be>2020-07-16 18:12:47 +0200
committerStijn Buys <ingar@telenet.be>2020-07-16 18:12:47 +0200
commiteda02d2c1f898e4c02ccd2317973c2b8463a7037 (patch)
tree9e1c593c2f052d1dd2ba24fd8daab6b0fc73aec6 /configure.ac
parent1d4e93e3bd49c0b93eca7696092ee8b356bd6cae (diff)
Make it work with Qt5.HEADmaster
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b008aff..0fe50fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ dnl
dnl see also http://qtnode.net/wiki/Qt_with_autotools
dnl
-AC_INIT(editor,0.1)
+AC_INIT(editor,0.2)
AC_CONFIG_HEADERS(src/config.h)
@@ -18,9 +18,9 @@ dnl
AC_MSG_CHECKING(Qt installation prefix)
QTDIR=xxx
AC_ARG_WITH([qt-prefix],
- AC_HELP_STRING([--with-qt-prefix=], [to specify the path to the Qt-4.8.0 installation prefix.]),
+ AC_HELP_STRING([--with-qt-prefix=], [to specify the path to the Qt5 installation prefix.]),
[QTPATHS="$withval"],
- [QTPATHS="/usr /usr/qt4 /opt/qt4"])
+ [QTPATHS="/usr /usr/qt5 /opt/qt5"])
for x in $QTPATHS; do
if test -d $x ; then
@@ -28,7 +28,7 @@ for x in $QTPATHS; do
fi
done
if test $QTDIR = xxx ; then
- AC_MSG_ERROR(Could not locate QT 4.1)
+ AC_MSG_ERROR(Could not locate Qt5)
fi
AC_MSG_RESULT($QTDIR)
@@ -38,7 +38,7 @@ dnl
AC_MSG_CHECKING(Qt includes directory)
AC_ARG_WITH([qt-includes],
- AC_HELP_STRING([--with-qt-includes], [to specify the path to directory containing the the Qt-4.8.0 includes.]),
+ AC_HELP_STRING([--with-qt-includes], [to specify the path to directory containing the the Qt5 includes.]),
[QTINCLUDEDIR="$withval"],
[QTINCLUDEDIR="$QTDIR/include"])
AC_MSG_RESULT($QTINCLUDEDIR)
@@ -48,7 +48,7 @@ dnl Qt libraries directory
dnl
AC_MSG_CHECKING(Qt libraries directory)
AC_ARG_WITH([qt-libraries],
- AC_HELP_STRING([--with-qt-libraries=], [to specify the path to directory containing the the Qt-4.8.0 libraries.]),
+ AC_HELP_STRING([--with-qt-libraries=], [to specify the path to directory containing the the Qt5 libraries.]),
[QTLIBDIR="$withval"],
[QTLIBDIR="$QTDIR/lib"])
AC_MSG_RESULT($QTLIBDIR)
@@ -70,15 +70,15 @@ host=`uname -a` # AC_CANONICAL_HOST is broken at the time of this writing.
case $host in
MINGW32*)
AC_MSG_NOTICE(win32)
- QTLIBS="-L$QTLIBDIR -lgdi32 -luser32 -lmingw32 -lqtmain -lQtGui4 -lQtCore4 -mthreads -Wl,-enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-reloc -Wl,-s -Wl,-s -Wl,-subsystem,windows"
- QTINC="-I$QTINCLUDEDIR -I$QTINCLUDEDIR/QtCore -I$QTINCLUDEDIR/QtGui -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -frtti -fexceptions"
+ QTLIBS="-L$QTLIBDIR -lgdi32 -luser32 -lmingw32 -lqtmain -lQt5Widgets -lQt5Gui -lQt5Core -mthreads -Wl,-enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-reloc -Wl,-s -Wl,-s -Wl,-subsystem,windows"
+ QTINC="-I$QTINCLUDEDIR -I$QTINCLUDEDIR/QtCore -I$QTINCLUDEDIR/QtGui -I$QTINCLUDEDIR/QtWidgets -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -frtti -fexceptions"
QTBIN="$QTDIR/bin"
;;
*)
AC_MSG_NOTICE(generic UNIX)
AC_PATH_XTRA
- QTINC="-I$QTINCLUDEDIR -I$QTINCLUDEDIR/QtGui -I$QTINCLUDEDIR/QtCore $X_CFLAGS -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED"
- QTLIBS="-Wl,-rpath,QTLIBDIR -L$QTLIBDIR -lQtGui -lQtCore -lpthread"
+ QTINC="-I$QTINCLUDEDIR -I$QTINCLUDEDIR/QtCore -I$QTINCLUDEDIR/QtGui -I$QTINCLUDEDIR/QtWidgets $X_CFLAGS -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED"
+ QTLIBS="-Wl,-rpath,QTLIBDIR -L$QTLIBDIR -lQt5Widgets -lQt5Gui -lQt5Core -lpthread"
QTBIN="$QTDIR/bin"
;;
esac