Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2013-11-03 19:06:51 +0000
committerStijn Buys <ingar@osirion.org>2013-11-03 19:06:51 +0000
commit596b210a358b63a7960f0d9caa27454fb511a6a4 (patch)
tree8230338560af9f032f7b77fd75e24dbeddc32e50 /configure.ac
parenteeb9eb02113f2c483cce404460b22f11997a5b0c (diff)
Added --disable-error option to the configure script to allow building without -Werror.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3acd841..4e607e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,12 +145,12 @@ dnl enable compiler warnings or not
dnl
AC_MSG_CHECKING(whether to abort on compiler warnings)
-WARN_CFLAGS=""
-AC_ARG_ENABLE(warn,
- AC_HELP_STRING([--disable-warn], [do not abort on compiler warnings]),
+WARN_CFLAGS="$WARN_CLFAGS -Wall"
+AC_ARG_ENABLE(error,
+ AC_HELP_STRING([--disable-error], [do not abort on compiler warnings]),
AC_MSG_RESULT(no),
AC_MSG_RESULT(yes)
- WARN_CFLAGS="$WARN_CFLAGS -Wall -Werror"
+ WARN_CFLAGS="$WARN_CFLAGS -Werror"
)
AC_SUBST(WARN_CFLAGS)