Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2011-04-17 14:21:29 +0000
committerStijn Buys <ingar@osirion.org>2011-04-17 14:21:29 +0000
commit09d68d3d1d77d45343e3562c0b5e0cd6816d47d3 (patch)
tree6b89c585fe8cd8bd49699cdb349566d3f382010e /configure.in
parent8264546908f1722b4d0f0e91c42dd791ba8535c4 (diff)
Initial Ogg Vorbis sounds effect support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f30d818..ee61ce4 100644
--- a/configure.in
+++ b/configure.in
@@ -411,6 +411,26 @@ else
AC_SUBST(LIBJPG_LIBS)
dnl ---------------------------------------------------------------
+ dnl Ogg Vorbis
+ dnl
+ AC_CHECK_HEADER(vorbis/vorbisfile.h,
+ [],
+ [AC_MSG_ERROR([vorbis/vorbisfile.h not found])]
+ )
+ AC_CHECK_HEADER(vorbis/codec.h,
+ [],
+ [AC_MSG_ERROR([vorbis/codec.h not found])]
+ )
+
+ AC_CHECK_LIB(vorbisfile, ov_fopen,
+ HAVE_VORBISFILE=yes
+ AC_DEFINE_UNQUOTED(HAVE_VORBISFILE, 1, [Define this if you have libvorbisfile]),
+ AC_MSG_ERROR([libvorbisfile not found])
+ )
+ LIBVORBISFILE_LIBS="-lvorbisfile"
+ AC_SUBST(LIBVORBISFILE_LIBS)
+
+ dnl ---------------------------------------------------------------
dnl SDL
dnl
@@ -526,7 +546,8 @@ build client ....... $BUILD_CLIENT])
if test "x$BUILD_CLIENT" = xyes; then
AC_MSG_RESULT([SDL ................ $LIBSDL_LIBS
opengl ............. $GL_LIBS
-openal ............. $AL_LIBS])
+openal ............. $AL_LIBS]
+vorbisfile ......... $LIBVORBISFILE_LIBS)
fi
AC_MSG_RESULT([