Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2011-02-17 13:09:51 +0000
committerStijn Buys <ingar@osirion.org>2011-02-17 13:09:51 +0000
commit0c5a4394c4b0382e96fdde6c11ab908f63a4c973 (patch)
tree6ca779689e7e13e70f9a38444db9a1556273fbba /configure.in
parente082e5055ec81fcec9e38e41baae488f59aabbfb (diff)
Removed SDL exception for MacOS from configure,
removed extern "C" from OpenGL function pointers.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in53
1 files changed, 20 insertions, 33 deletions
diff --git a/configure.in b/configure.in
index d9f577d..f30d818 100644
--- a/configure.in
+++ b/configure.in
@@ -81,7 +81,6 @@ case "$host" in
HOST_LIBS=""
HOST_GL_LIBS="-framework OpenGL"
HOST_AL_LIBS="-framework OpenAL"
- HOST_SDL_LIBS="-framework SDL -framework Cocoa"
ICON_CLIENT=""
ICON_SERVER=""
SDLMAIN="SDLMain.o"
@@ -415,43 +414,31 @@ else
dnl SDL
dnl
- if test "x${OS}" = "xOSX"; then
- AC_CHECK_HEADER(SDL/SDL.h,
- [],
- [AC_MSG_ERROR([SDL/SDL.h not found])]
- )
-
- LIBSDL_LIBS="$HOST_SDL_LIBS"
- LIBSDL_CFLAGS="$HOST_SDL_LIBS"
- AC_SUBST(LIBSDL_LIBS)
- AC_SUBST(LIBSDL_CFLAGS)
- else
- AC_MSG_CHECKING([looking for SDL])
- KDE_FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin], [
+ AC_MSG_CHECKING([looking for SDL])
+ KDE_FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin], [
AC_MSG_ERROR([SDL not found])
- ])
+ ])
- if test -n "$LIBSDL_CONFIG"; then
- LIBSDL_LIBS="`$LIBSDL_CONFIG --libs`"
- LIBSDL_RPATH=
- for args in $LIBSDL_LIBS; do
- case $args in
- -L*)
- LIBSDL_RPATH="$LIBSDL_RPATH $args"
- ;;
- esac
- done
+ if test -n "$LIBSDL_CONFIG"; then
+ LIBSDL_LIBS="`$LIBSDL_CONFIG --libs`"
+ LIBSDL_RPATH=
+ for args in $LIBSDL_LIBS; do
+ case $args in
+ -L*)
+ LIBSDL_RPATH="$LIBSDL_RPATH $args"
+ ;;
+ esac
+ done
- LIBSDL_RPATH=`echo $LIBSDL_RPATH | sed -e "s/-L/-R/g"`
- LIBSDL_CFLAGS="`$LIBSDL_CONFIG --cflags`"
- fi
+ LIBSDL_RPATH=`echo $LIBSDL_RPATH | sed -e "s/-L/-R/g"`
+ LIBSDL_CFLAGS="`$LIBSDL_CONFIG --cflags`"
+ fi
- AC_MSG_RESULT($HAVE_LIBSDL)
+ AC_MSG_RESULT($HAVE_LIBSDL)
- AC_SUBST(LIBSDL_LIBS)
- AC_SUBST(LIBSDL_CFLAGS)
- AC_SUBST(LIBSDL_RPATH)
- fi
+ AC_SUBST(LIBSDL_LIBS)
+ AC_SUBST(LIBSDL_CFLAGS)
+ AC_SUBST(LIBSDL_RPATH)
BUILD_CLIENT=yes
AC_DEFINE_UNQUOTED(BUILD_CLIENT, 1, [Define this to build the client])