Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2009-02-24 18:55:52 +0000
committerStijn Buys <ingar@osirion.org>2009-02-24 18:55:52 +0000
commit0e96454c70e56de5cefa38ab1b5dc46196238d07 (patch)
tree93e99e8b30ce055cc9483e4b1c6859d4dec09847 /configure.in
parent59eb4d2b1a750077523c8e1c380785d08f83feb9 (diff)
fix configure.in, Objective-C ignore dependencies for Objective-C targets (SDLMain.m)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1b3c803..7c3f645 100644
--- a/configure.in
+++ b/configure.in
@@ -89,7 +89,17 @@ case "$host" in
OS=OSX
AC_MSG_RESULT(OS X)
AC_DEFINE_UNQUOTED(_OSX, 1, [Define this if you're building for native OS X])
- AC_PROG_OBJC
+dnl
+dnl Don't rely on AC_PROG_OBJC presence (e.g. autoconf 2.59)
+dnl http://www.mail-archive.com/xine-cvslog@lists.sourceforge.net/msg01693.html
+dnl
+ m4_ifdef(
+ [AC_PROG_OBJC],
+ [AC_PROG_OBJC],
+ [AC_CHECK_TOOL([OBJC], [gcc])
+ AC_SUBST(OBJC)
+ AC_SUBST(OBJCFLAGS)]
+ )
;;
*-*-mingw*)
@@ -115,6 +125,13 @@ case "$host" in
OS=UNIX
;;
esac
+
+dnl
+dnl Make Objective-C work with automake 1.7.x
+dnl http://mlblog.osdir.com/sysutils.automake.general/2003-05/msg00030.shtml
+dnl
+AM_CONDITIONAL([am__fastdepOBJC], false)
+
AC_SUBST(OS)
AC_SUBST(HOST_LIBS)
AC_SUBST(ICON_CLIENT)
@@ -414,7 +431,7 @@ dnl ---------------------------------------------------------------
dnl Configuration summary
AC_MSG_RESULT([
-The Osirion Project $VERSION
+Project::OSiRiON $VERSION
Configuration summary:
platform ........... $host
@@ -422,6 +439,7 @@ Configuration summary:
libraries .......... $HOST_LIBS $LIBJPG_LIBS $LIBPNG_LIBS
curses ............. $HAVE_CURSES
build client ....... $BUILD_CLIENT
+ SDL .................$LIBSDL_LIBS
opengl ............. $GL_LIBS
openal ............. $AL_LIBS