Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-03-26 18:10:17 +0000
committerStijn Buys <ingar@osirion.org>2008-03-26 18:10:17 +0000
commit2b9f068e7ee4c0d249c715f9eb5a3c2c8a11e6f8 (patch)
treefcd373f97385dc150437bc09b2143e0ceee589e1 /configure.in
parenta29aa1ee2935857f616351a23578311f514516d4 (diff)
win32 updates
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 13d7060..1b03846 100644
--- a/configure.in
+++ b/configure.in
@@ -62,6 +62,21 @@ AC_DEFUN([KDE_FIND_PATH],
fi
])
+AC_MSG_CHECKING([host type])
+case "$host" in
+ *-*-mingw*)
+ HOST_LIBS="-lws2_32"
+ HOST_GL_LIBS="-lopengl32 -lglu32"
+ AC_MSG_RESULT(win32)
+ ;;
+ *)
+ HOST_LIBS=""
+ HOST_GL_LIBS="-lGL -lGLU"
+ AC_MSG_RESULT(generic unix)
+ ;;
+esac
+AC_SUBST(HOST_LIBS)
+
AC_MSG_CHECKING(whether to abort on compiler warnings)
WARN_CFLAGS=""
AC_ARG_ENABLE(warn,
@@ -98,17 +113,15 @@ AC_CHECK_HEADER(GL/glext.h,
[#include <GL/gl.h>]
)
-AC_CHECK_LIB(GL, glVertex3f,
- GL_LIBS="$GL_LIBS -lGL -lGLU"
-)
+GL_LIBS="$HOST_GL_LIBS"
AC_SUBST(GL_LIBS)
AC_SUBST(GL_CFLAGS)
AC_MSG_CHECKING([looking for SDL])
KDE_FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin], [
- AC_MSG_WARN([Could not find libsdl anywhere, check http://www.sdl.org])
+ AC_MSG_WARN([Could not find libSDL, check http://www.sdl.org])
])
if test -n "$LIBSDL_CONFIG"; then
@@ -178,6 +191,8 @@ The Osirion Project $VERSION
Configuration summary:
platform ........... $host
flags .............. $CXXFLAGS
+ libraries .......... $HOST_LIBS
+ opengl ............. $GL_LIBS
Installation directories:
prefix ............. $PACKAGE_PREFIX