Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-02-06 21:49:14 +0000
committerStijn Buys <ingar@osirion.org>2008-02-06 21:49:14 +0000
commit598dba9d17838e92f89bcd3ec78c69cc4ce50044 (patch)
tree08a818d6f4dc6a605baa8ddced6165b7bc72ba1f /configure.in
parent884667848ecf043dd2d8c5421250c88931151bd1 (diff)
minor cleanups
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 29 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 96b21c8..d59ae64 100644
--- a/configure.in
+++ b/configure.in
@@ -9,7 +9,7 @@ AM_PROG_LIBTOOL
dnl KDE_FIND_PATH(programm-name, variable-name, list of directories,
dnl if-not-found, test-parameter)
-AC_DEFUN(KDE_FIND_PATH,
+AC_DEFUN([KDE_FIND_PATH],
[
AC_MSG_CHECKING([for $1])
if test -n "$$2"; then
@@ -133,14 +133,39 @@ AC_SUBST(LIBSDL_LIBS)
AC_SUBST(LIBSDL_CFLAGS)
AC_SUBST(LIBSDL_RPATH)
-
CXXFLAGS="-pipe $DEBUG_CFLAGS $WARN_CFLAGS $CXXFLAGS"
AC_SUBST(CXXFLAGS)
+dnl ---------------------------------------------------------------
+dnl Installation paths
+
+test "$prefix" = "NONE" && prefix="/opt/games/$PACKAGE"
+
+BINDIR="$prefix"
+LIBDIR="$prefix/lib"
+AC_DEFINE_UNQUOTED(LIBDIR, "$LIBDIR",
+ [Define this to the path containing the game libraries.]
+)
+
+DATADIR="$prefix/data"
+AC_DEFINE_UNQUOTED(DATADIR, "$DATADIR",
+ [Define this to the path containing the game data.]
+)
+
+AC_SUBST(BINDIR)
+AC_SUBST(LIBDIR)
+AC_SUBST(DATATDIR)
+
+dnl ---------------------------------------------------------------
+dnl Write makefiles and config.h
+
AC_OUTPUT(Makefile src/Makefile src/client/Makefile src/core/Makefile \
src/filesystem/Makefile src/game/Makefile src/math/Makefile src/render/Makefile src/server/Makefile \
src/sys/Makefile)
+dnl ---------------------------------------------------------------
+dnl Configuration summary
+
AC_MSG_RESULT([
The Osirion Project $VERSION
@@ -149,8 +174,8 @@ Configuration summary:
flags .............. $CXXFLAGS
Installation directories:
- prefix ............. $PREFIX
- program binaries ... $BINDIR
+ prefix ............. $prefix
+ binaries ........... $BINDIR
libraries .......... $LIBDIR
data ............... $DATADIR
])