Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-02-08 19:24:55 +0000
committerStijn Buys <ingar@osirion.org>2008-02-08 19:24:55 +0000
commit74031d8f7d91fe70d0ae447d74a12c5206ea9b62 (patch)
treedf6b1f5529aeb746b3547912d7ed1c0f78b20d1e /configure.in
parentd3477eedc113a2c126f36f41384b8921d610906a (diff)
minor cleanups
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 21 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index d59ae64..83aa028 100644
--- a/configure.in
+++ b/configure.in
@@ -141,26 +141,33 @@ dnl Installation paths
test "$prefix" = "NONE" && prefix="/opt/games/$PACKAGE"
-BINDIR="$prefix"
-LIBDIR="$prefix/lib"
-AC_DEFINE_UNQUOTED(LIBDIR, "$LIBDIR",
- [Define this to the path containing the game libraries.]
+PACKAGE_PREFIX="$prefix"
+PACKAGE_BINDIR="$prefix/bin"
+PACKAGE_DATADIR="$prefix/data"
+PACKAGE_LIBDIR="$prefix/lib"
+
+AC_DEFINE_UNQUOTED(PACKAGE_PREFIX, "$PACKAGE_PREFIX",
+ [Define this to the path where the game will be installed.]
+)
+
+AC_DEFINE_UNQUOTED(PACKAGE_BINDIR, "$PACKAGE_BINDIR",
+ [Define this to the path containing the game binaries.]
)
-DATADIR="$prefix/data"
-AC_DEFINE_UNQUOTED(DATADIR, "$DATADIR",
+AC_DEFINE_UNQUOTED(PACKAGE_DATADIR, "$PACKAGE_DATADIR",
[Define this to the path containing the game data.]
)
-AC_SUBST(BINDIR)
-AC_SUBST(LIBDIR)
-AC_SUBST(DATATDIR)
+AC_DEFINE_UNQUOTED(PACKAGE_LIBDIR, "$PACKAGE_LIBDIR",
+ [Define this to the path containing the game libraries.]
+)
dnl ---------------------------------------------------------------
dnl Write makefiles and config.h
AC_OUTPUT(Makefile src/Makefile src/client/Makefile src/core/Makefile \
- src/filesystem/Makefile src/game/Makefile src/math/Makefile src/render/Makefile src/server/Makefile \
+ src/filesystem/Makefile src/game/Makefile src/math/Makefile \
+ src/render/Makefile src/server/Makefile \
src/sys/Makefile)
dnl ---------------------------------------------------------------
@@ -174,9 +181,9 @@ Configuration summary:
flags .............. $CXXFLAGS
Installation directories:
- prefix ............. $prefix
- binaries ........... $BINDIR
- libraries .......... $LIBDIR
- data ............... $DATADIR
+ prefix ............. $PACKAGE_PREFIX
+ binaries ........... $PACKAGE_BINDIR
+ libraries .......... $PACKAGE_LIBDIR
+ data ............... $PACKAGE_DATADIR
])