Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-08-24 18:52:10 +0000
committerStijn Buys <ingar@osirion.org>2008-08-24 18:52:10 +0000
commit9c4d134ab304794b755139e90ca6da9de73a1e9a (patch)
tree71373947f86aa5f72ea78fed695974cfb5117642 /configure.in
parent184598a43548642b9a4bfe8c2fce58e4a966d0bb (diff)
JPEG screenshots
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 13 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 3c6db7a..380569d 100644
--- a/configure.in
+++ b/configure.in
@@ -179,7 +179,7 @@ else
AC_CHECK_HEADER(GL/gl.h,
HAVE_OPENGL=yes
AC_DEFINE(HAVE_OPENGL, 1, [Define this if you have OpenGL]),
- AC_MSG_WARN([OpenGL include file GL/gl.h not found])
+ AC_MSG_ERROR([OpenGL include file GL/gl.h not found])
)
AC_CHECK_HEADER(GL/glext.h,
@@ -194,14 +194,21 @@ else
AC_SUBST(GL_CFLAGS)
AC_CHECK_HEADER(png.h,
- HAVE_OPENGL=yes
- AC_DEFINE(HAVE_PNG, 1, [Define this if you have libpng]),
- AC_MSG_WARN([libpng include file png.h not found])
+ HAVE_LIBPNG=yes
+ AC_DEFINE(HAVE_LIBPNG, 1, [Define this if you have libpng]),
+ AC_MSG_ERROR([libpng include file png.h not found])
)
-
LIBPNG_LIBS="-lpng"
AC_SUBST(LIBPNG_LIBS)
+ AC_CHECK_HEADER(jpeglib.h,
+ HAVE_LIBJPEG=yes
+ AC_DEFINE(HAVE_LIBJPEG, 1, [Define this if you have libjpeg]),
+ AC_MSG_ERROR([libjpeg include file jpeglib.h not found])
+ )
+ LIBJPG_LIBS="-ljpeg"
+ AC_SUBST(LIBJPG_LIBS)
+
AC_CHECK_HEADER(AL/al.h,
HAVE_OPENGL=yes
AC_DEFINE(HAVE_OPENAL, 1, [Define this if you have OpenAL]),
@@ -293,7 +300,7 @@ The Osirion Project $VERSION
Configuration summary:
platform ........... $host
flags .............. $CXXFLAGS
- libraries .......... $HOST_LIBS
+ libraries .......... $HOST_LIBS $LIBJPG_LIBS $LIBPNG_LIBS
ncurses ............ $HAVE_CURSES
build client ....... $BUILD_CLIENT
opengl ............. $GL_LIBS