Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-05-18 12:15:29 +0000
committerStijn Buys <ingar@osirion.org>2008-05-18 12:15:29 +0000
commitcc0a133a616aeff57887b27497e4a978b5697c04 (patch)
tree978223dd6ecdd79400ba89630747c8b7c120fd9b /configure.in
parent9ce3a1e6aa40713db5dd11aba3595fb0ad75cc60 (diff)
use native openal library on win32
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6ea1e8c..e4ec169 100644
--- a/configure.in
+++ b/configure.in
@@ -67,6 +67,7 @@ case "$host" in
*-*-mingw*)
HOST_LIBS="-lws2_32"
HOST_GL_LIBS="-lopengl32 -lglu32"
+ HOST_AL_LIBS="-lOpenAL32"
ICON_CLIENT="osirion-res.o"
ICON_SERVER="osiriond-res.o"
AC_MSG_RESULT(win32)
@@ -74,6 +75,7 @@ case "$host" in
*)
HOST_LIBS=""
HOST_GL_LIBS="-lGL -lGLU"
+ HOST_AL_LIBS="-lopenal"
ICON_CLIENT=""
ICON_SERVER=""
AC_MSG_RESULT(generic unix)
@@ -131,7 +133,7 @@ AC_CHECK_HEADER(AL/al.h,
HAVE_OPENAL=no
)
-AL_LIBS="-lopenal"
+AL_LIBS="$HOST_AL_LIBS"
AC_SUBST(AL_LIBS)
AC_MSG_CHECKING([looking for SDL])
@@ -208,6 +210,7 @@ Configuration summary:
flags .............. $CXXFLAGS
libraries .......... $HOST_LIBS
opengl ............. $GL_LIBS
+ openal ............. $AL_LIBS
Installation directories:
prefix ............. $PACKAGE_PREFIX