Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-01-31 18:22:44 +0000
committerStijn Buys <ingar@osirion.org>2008-01-31 18:22:44 +0000
commitf794b9ee52293cefd6ac73fdf0d2a01c5388f057 (patch)
tree2838d7ee11ae49e2e519ad604ba41f7071fb8288 /configure.in
parent1ddff2045848da5136e9e8131e335ac7626b8f68 (diff)
modular system works now
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 11 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index 3b0b911..0a52322 100644
--- a/configure.in
+++ b/configure.in
@@ -75,16 +75,14 @@ AC_ARG_ENABLE(warn,
AC_SUBST(WARN_CFLAGS)
-AC_MSG_CHECKING(whether to build a debug version)
-DEBUG_CFLAGS=""
-AC_ARG_ENABLE(debug,
+AC_MSG_CHECKING(whether to include debug messages)
+AC_ARG_ENABLE(debug_messages,
AC_HELP_STRING(
- [--disable-debug], [build without extra debug information]
+ [--disable-debug-messages], [build without extra debug information]
),
AC_MSG_RESULT(no),
AC_MSG_RESULT(yes)
- AC_DEFINE_UNQUOTED(HAVE_DEBUG, 1, [Defines if debug information is enabled])
- HAVE_DEBUG="-g"
+ AC_DEFINE_UNQUOTED(HAVE_DEBUG_MESSAGES, 1, [Defines if debug information is enabled])
)
AC_CHECK_HEADER(GL/gl.h,
@@ -152,18 +150,14 @@ AC_MSG_RESULT([
The Osirion Project $VERSION
Configuration summary:
-
- platform ...................... $host
-
- flags ......................... $CXXFLAGS
- debug information ............. $HAVE_DEBUG
+ platform ........... $host
+ flags .............. $CXXFLAGS
+ debug messages ..... $debug_messages
Installation directories:
-
- prefix ........................ $PREFIX
- program binaries .............. $BINDIR
- libraries ..................... $LIBDIR
- data .......................... $DATADIR
-
+ prefix ............. $PREFIX
+ program binaries ... $BINDIR
+ libraries .......... $LIBDIR
+ data ............... $DATADIR
])