Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-02-02 13:23:00 +0000
committerStijn Buys <ingar@osirion.org>2008-02-02 13:23:00 +0000
commitcdc5a69a108654ff378839e8cf93669de31ff9c5 (patch)
tree10bdc47d0d51485f49387bee3aeae7037c47df6e /src/Makefile.am
parent1765b93250ac3b89947c3da7f0c7266a910367c9 (diff)
removed libcommon
modularized client and server
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ad350fc..cd06cd7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,17 @@
# set the include path found by configure
AM_CPPFLAGS = $(DEBUG_CFLAGS) $(WARN_CFLAGS) $(all_includes)
+INCLUDES = -I$(top_srcdir)/src
+SUBDIRS = math sys filesystem core game server gl client
-SUBDIRS = math common sys filesystem core game server gl client
+noinst_HEADERS = config.h
+bin_PROGRAMS = osiriond osirion
+# dedicated server
+osiriond_SOURCES = osiriond.cc
+osiriond_LDADD = $(top_builddir)/src/server/libserver.la
+# client
+osirion_SOURCES = osirion.cc
+osirion_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
+osirion_LDADD = $(top_builddir)/src/client/libclient.la
+osirion_LDFLAGS = $(LIBSDL_LIBS) $(GL_LIBS)