Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-01-30 17:32:00 +0000
committerStijn Buys <ingar@osirion.org>2008-01-30 17:32:00 +0000
commita94049b1a43f83d750b9b5dee031c19a6b1fafb0 (patch)
tree8677f67ba0ba0c0bb80b911d3aa0413d7e2a47c0 /src/client/Makefile.am
parent7b5777160c7615443afc287fbdad6a861d69e36b (diff)
accomodate the new modules
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index 12b8f5d..6298936 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -1,16 +1,17 @@
METASOURCES = AUTO
bin_PROGRAMS = osirion
-osirion_LDADD = $(top_builddir)/src/game/libgame.la \
- $(top_builddir)/src/gl/libosiriongl.la
+
+osirion_LDADD = $(top_builddir)/src/common/libcommon.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la \
+ $(top_builddir)/src/game/libgame.la \
+ $(top_builddir)/src/gl/libgl.la
osirion_SOURCES = camera.cc client.cc console.cc hud.cc input.cc main.cc \
shipdrawer.cc stardrawer.cc video.cc view.cc
-
-
INCLUDES = -I$(top_srcdir)/src
-osirion_CFLAGS = $(LIBSDL_CFLAGS)
-osirion_LDFLAGS = $(LIBSDL_LIBS)
+osirion_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
+osirion_LDFLAGS = $(LIBSDL_LIBS) $(GL_LIBS)
noinst_HEADERS = camera.h client.h console.h input.h shipdrawer.h stardrawer.h \
video.h view.h