Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2007-10-28 09:20:41 +0000
committerStijn Buys <ingar@osirion.org>2007-10-28 09:20:41 +0000
commitbb24e4ad543c3a739625778b9854c49688c8204f (patch)
tree09b1edcc16f48b78f76643800dcb53d201d8bb20 /src/client/Makefile.am
parentcad1758bb8b092b804f9cc701aeb730e570b173b (diff)
SDL LDFLAGS
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index a86d8f0..3df02d3 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -2,7 +2,7 @@
METASOURCES = AUTO
bin_PROGRAMS = osirion
osirion_LDADD = $(top_builddir)/src/game/libgame.la \
- $(top_builddir)/src/gl/libosiriongl.la -lSDL
+ $(top_builddir)/src/gl/libosiriongl.la
osirion_SOURCES = camera.cc camera.h client.cc client.h input.cc input.h \
main.cc shipdrawer.cc shipdrawer.h stardrawer.cc stardrawer.h video.cc video.h \
view.cc view.h console.cc console.h
@@ -10,4 +10,6 @@ osirion_SOURCES = camera.cc camera.h client.cc client.h input.cc input.h \
INCLUDES = -I$(top_srcdir)/src
-osirion_LDFLAGS = -L/usr/X11/lib64
+osirion_CFLAGS = $(LIBSDL_CFLAGS)
+osirion_LDFLAGS = $(LIBSDL_LIBS)
+