Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-02-02 13:23:00 +0000
committerStijn Buys <ingar@osirion.org>2008-02-02 13:23:00 +0000
commitcdc5a69a108654ff378839e8cf93669de31ff9c5 (patch)
tree10bdc47d0d51485f49387bee3aeae7037c47df6e /src/client/Makefile.am
parent1765b93250ac3b89947c3da7f0c7266a910367c9 (diff)
removed libcommon
modularized client and server
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index 9807963..f1a3f9d 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -1,17 +1,13 @@
-
METASOURCES = AUTO
-bin_PROGRAMS = osirion
-
-osirion_LDADD = $(top_builddir)/src/math/libmath.la \
- $(top_builddir)/src/common/libcommon.la $(top_builddir)/src/sys/libsys.la \
- $(top_builddir)/src/filesystem/libfilesystem.la $(top_builddir)/src/core/libcore.la $(top_builddir)/src/game/libgame.la \
- $(top_builddir)/src/gl/libgl.la
-osirion_SOURCES = application.cc camera.cc client.cc console.cc hud.cc input.cc main.cc \
- shipdrawer.cc stardrawer.cc video.cc view.cc
-
INCLUDES = -I$(top_srcdir)/src
-osirion_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
-osirion_LDFLAGS = $(LIBSDL_LIBS) $(GL_LIBS)
+libclient_la_SOURCES = application.cc camera.cc client.cc console.cc hud.cc input.cc \
+ shipdrawer.cc stardrawer.cc video.cc view.cc
+libclient_la_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
+libclient_la_LDFLAGS = -avoid-version -no-undefined $(GL_LIBS) $(LIBSDL_LIBS)
+noinst_LTLIBRARIES = libclient.la
noinst_HEADERS = application.h camera.h client.h console.h input.h shipdrawer.h stardrawer.h \
- video.h view.h
+ video.h view.h
+libclient_la_LIBADD = $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/sys/libsys.la $(top_builddir)/src/filesystem/libfilesystem.la \
+ $(top_builddir)/src/core/libcore.la $(top_builddir)/src/game/libgame.la $(top_builddir)/src/gl/libgl.la