Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2010-10-17 17:19:03 +0000
committerStijn Buys <ingar@osirion.org>2010-10-17 17:19:03 +0000
commitd6e4c4e7c2b1e28961f1dfe2f25ef96ced60b21b (patch)
tree63744dff093a8b23f65d9c68b922b678805647d9 /src/core/Makefile.am
parentea6e6bb769d713ac55114c1940626f13e384ebed (diff)
core bullet physics support,
initial vstrafe support
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am73
1 files changed, 64 insertions, 9 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index 6085085..7155f86 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -1,17 +1,72 @@
METASOURCES = AUTO
INCLUDES = -I$(top_srcdir)/src
-libcore_la_SOURCES = application.cc commandbuffer.cc core.cc cvar.cc \
- descriptions.cc entity.cc extension.cc func.cc gameconnection.cc gameinterface.cc \
- gameserver.cc info.cc item.cc inventory.cc label.cc loader.cc module.cc netclient.cc \
- netconnection.cc netplayer.cc netserver.cc parser.cc player.cc stats.cc timer.cc zone.cc
+noinst_LTLIBRARIES = libcore.la
+
libcore_la_LDFLAGS = -avoid-version -no-undefined
+
libcore_la_LIBADD = $(top_builddir)/src/model/libmodel.la \
$(top_builddir)/src/filesystem/libfilesystem.la $(top_builddir)/src/math/libmath.la $(top_builddir)/src/sys/libsys.la \
$(top_builddir)/src/auxiliary/libauxiliary.la
-noinst_LTLIBRARIES = libcore.la
-noinst_HEADERS = application.h commandbuffer.h core.h cvar.h entity.h func.h \
- gameconnection.h gameinterface.h gameserver.h label.h message.h module.h net.h netclient.h \
- netconnection.h netserver.h player.h range.h stats.h timer.h parser.h descriptions.h \
- extension.h loader.h info.h item.h inventory.h zone.h
+
+libcore_la_SOURCES = \
+ application.cc \
+ commandbuffer.cc \
+ core.cc \
+ cvar.cc \
+ descriptions.cc \
+ entity.cc \
+ extension.cc \
+ func.cc \
+ gameconnection.cc \
+ gameinterface.cc \
+ gameserver.cc \
+ info.cc \
+ inventory.cc \
+ item.cc \
+ label.cc \
+ loader.cc \
+ module.cc \
+ netclient.cc \
+ netconnection.cc \
+ netplayer.cc \
+ netserver.cc \
+ parser.cc \
+ physics.cc \
+ player.cc \
+ stats.cc \
+ timer.cc \
+ zone.cc
+
+noinst_HEADERS = \
+ application.h \
+ commandbuffer.h \
+ core.h \
+ cvar.h \
+ descriptions.h \
+ entity.h \
+ extension.h \
+ func.h \
+ gameconnection.h \
+ gameinterface.h \
+ gameserver.h \
+ info.h \
+ inventory.h \
+ item.h \
+ label.h \
+ loader.h \
+ message.h \
+ module.h \
+ netclient.h \
+ netconnection.h \
+ net.h \
+ netplayer.h \
+ netserver.h \
+ parser.h \
+ physics.h \
+ player.h \
+ range.h \
+ stats.h \
+ timer.h \
+ zone.h