Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-01-30 17:28:41 +0000
committerStijn Buys <ingar@osirion.org>2008-01-30 17:28:41 +0000
commite3c27429831245a151706c395991b42f2876b2e1 (patch)
tree4316cf546d073b87d4c2345a89905cdaafd795b1 /src/core/Makefile.am
parentc6414cfbeb25d9e4df783264d32f31de48241347 (diff)
core subsystem
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
new file mode 100644
index 0000000..0f0020f
--- /dev/null
+++ b/src/core/Makefile.am
@@ -0,0 +1,12 @@
+METASOURCES = AUTO
+INCLUDES = -I$(top_srcdir)/src
+
+libcore_la_SOURCES = core.cc
+libcore_la_LDFLAGS = -avoid-version -no-undefined
+libcore_la_LIBADD = $(top_builddir)/src/common/libcommon.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la
+
+noinst_LTLIBRARIES = libcore.la
+noinst_HEADERS = core.h
+