Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2010-11-16 19:26:53 +0000
committerStijn Buys <ingar@osirion.org>2010-11-16 19:26:53 +0000
commit2daac503a3a2f149f883db7c30199ebbb1f00c7f (patch)
tree6f53bf73d376b6458b173b8d25fd8b420a47911f /src/game/Makefile.am
parent2056ffa670f6d86ad7c9736ebf2886df3753dbbe (diff)
cleaned up autoconf/automake project files, this should solve build order and dependency issues
Diffstat (limited to 'src/game/Makefile.am')
-rw-r--r--src/game/Makefile.am29
1 files changed, 22 insertions, 7 deletions
diff --git a/src/game/Makefile.am b/src/game/Makefile.am
index 47ca032..2aaf56f 100644
--- a/src/game/Makefile.am
+++ b/src/game/Makefile.am
@@ -1,11 +1,26 @@
-INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
METASOURCES = AUTO
-
-libgame_la_LDFLAGS = -avoid-version
-libgame_la_SOURCES = game.cc
+INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
+SUBDIRS = base example intro
noinst_LTLIBRARIES = libgame.la
noinst_HEADERS = game.h
-SUBDIRS = base example intro
-libgame_la_LIBADD = $(top_builddir)/src/game/base/libbase.la \
- $(top_builddir)/src/game/intro/libintro.la $(top_builddir)/src/game/example/libexample.la
+
+libgame_la_SOURCES = game.cc
+
+libgame_la_LDFLAGS = -avoid-version -no-undefined
+
+libgame_la_DEPENDENCIES = \
+ $(top_builddir)/src/auxiliary/libauxiliary.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/sys/libsys.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la \
+ $(top_builddir)/src/model/libmodel.la \
+ $(top_builddir)/src/core/libcore.la \
+ $(top_builddir)/src/game/base/libbase.la \
+ $(top_builddir)/src/game/example/libexample.la \
+ $(top_builddir)/src/game/intro/libintro.la
+
+libgame_la_LIBADD = \
+ $(top_builddir)/src/game/base/libbase.la \
+ $(top_builddir)/src/game/example/libexample.la \
+ $(top_builddir)/src/game/intro/libintro.la