Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2007-10-21 23:03:29 +0000
committerStijn Buys <ingar@osirion.org>2007-10-21 23:03:29 +0000
commit621f4ad1d509665e19738525c80e104b80fb7b26 (patch)
tree8c3ff6cc028dcbebfb616b38f9ae443c628cc58f /src/game/Makefile.am
parenta237a2d7723b94df6cd3e91401ec28388de6f1a0 (diff)
automake updates
Diffstat (limited to 'src/game/Makefile.am')
-rw-r--r--src/game/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/game/Makefile.am b/src/game/Makefile.am
index 9e86c15..537bb3a 100644
--- a/src/game/Makefile.am
+++ b/src/game/Makefile.am
@@ -1,9 +1,10 @@
METASOURCES = AUTO
-libgame_la_LDFLAGS = -avoid-version
+libgame_la_LDFLAGS = -avoid-version -no-undefined
noinst_LTLIBRARIES = libgame.la
-libgame_la_SOURCES = console.h file.cc file.h game.cc game.h player.h sector.h \
- ship.cc ship.h star.cc star.h world.h
+libgame_la_SOURCES = game.cc game.h player.h sector.h ship.cc ship.h star.cc \
+ star.h world.h
INCLUDES = -I$(top_srcdir)/src
-noinst_HEADERS = console.h file.h sector.h world.h
+noinst_HEADERS = sector.h world.h
+libgame_la_LIBADD = $(top_builddir)/src/common/libcommon.la