Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-01-30 17:35:04 +0000
committerStijn Buys <ingar@osirion.org>2008-01-30 17:35:04 +0000
commitbac8343bbc9f1e4cf97a561c732054539f21f03d (patch)
tree4d8997f26c6d63ed4ad61fc1057752f0c1b27ca1 /src/game/Makefile.am
parent69f7ffa70863bef2be4cae08c466b5d97a627277 (diff)
accomodate the new modules
Diffstat (limited to 'src/game/Makefile.am')
-rw-r--r--src/game/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/game/Makefile.am b/src/game/Makefile.am
index fc1b23e..4268c84 100644
--- a/src/game/Makefile.am
+++ b/src/game/Makefile.am
@@ -1,9 +1,11 @@
-
+INCLUDES = -I$(top_srcdir)/src
METASOURCES = AUTO
-libgame_la_LDFLAGS = -avoid-version -no-undefined
-noinst_LTLIBRARIES = libgame.la
+libgame_la_LDFLAGS = -avoid-version -no-undefined
libgame_la_SOURCES = game.cc sector.cc ship.cc shipspecs.cc star.cc
-INCLUDES = -I$(top_srcdir)/src
-libgame_la_LIBADD = $(top_builddir)/src/common/libcommon.la
+libgame_la_LIBADD = $(top_builddir)/src/common/libcommon.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la
+
+noinst_LTLIBRARIES = libgame.la
noinst_HEADERS = game.h player.h sector.h ship.h shipspecs.h star.h world.h