Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-01-30 17:30:10 +0000
committerStijn Buys <ingar@osirion.org>2008-01-30 17:30:10 +0000
commit4fd8d5c71365e58e6dff36fc756d8e2e55204db7 (patch)
tree851c86f497ce3bfa7050ae5634f50f888d6d80f8 /src/math/Makefile.am
parent28180e6b6763e4ce5d65c02e4df5380f11e6d10a (diff)
math module
Diffstat (limited to 'src/math/Makefile.am')
-rw-r--r--src/math/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/math/Makefile.am b/src/math/Makefile.am
new file mode 100644
index 0000000..78a52fc
--- /dev/null
+++ b/src/math/Makefile.am
@@ -0,0 +1,9 @@
+METASOURCES = AUTO
+
+libmath_la_SOURCES = color.cc functions.cc plane.cc vector3f.cc
+libmath_la_LDFLAGS = -lm -avoid-version -no-undefined
+
+noinst_LTLIBRARIES = libmath.la
+noinst_HEADERS = color.h functions.h mathlib.h plane.h vector3f.h
+
+INCLUDES = -I$(top_srcdir)/src