Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2010-11-16 19:26:53 +0000
committerStijn Buys <ingar@osirion.org>2010-11-16 19:26:53 +0000
commit2daac503a3a2f149f883db7c30199ebbb1f00c7f (patch)
tree6f53bf73d376b6458b173b8d25fd8b420a47911f /src/model/Makefile.am
parent2056ffa670f6d86ad7c9736ebf2886df3753dbbe (diff)
cleaned up autoconf/automake project files, this should solve build order and dependency issues
Diffstat (limited to 'src/model/Makefile.am')
-rw-r--r--src/model/Makefile.am38
1 files changed, 32 insertions, 6 deletions
diff --git a/src/model/Makefile.am b/src/model/Makefile.am
index 6a44471..3d9d7c0 100644
--- a/src/model/Makefile.am
+++ b/src/model/Makefile.am
@@ -1,12 +1,38 @@
METASOURCES = AUTO
+INCLUDES = -I$(top_srcdir)/src
-libmodel_la_SOURCES = asefile.cc fragment.cc mapfile.cc material.cc \
- model.cc face.cc primitives.cc quad.cc tags.cc triangle.cc vertexarray.cc
-libmodel_la_LDFLAGS = -avoid-version -no-undefined -lm
noinst_LTLIBRARIES = libmodel.la
-noinst_HEADERS = asefile.h fragment.h mapfile.h material.h model.h face.h \
- primitives.h quad.h tags.h triangle.h vertexarray.h
+noinst_HEADERS = \
+ asefile.h \
+ face.h \
+ fragment.h \
+ mapfile.h \
+ material.h \
+ model.h \
+ primitives.h \
+ quad.h \
+ tags.h \
+ triangle.h \
+ vertexarray.h
-INCLUDES = -I$(top_srcdir)/src
+libmodel_la_SOURCES = \
+ asefile.cc \
+ face.cc \
+ fragment.cc \
+ mapfile.cc \
+ material.cc \
+ model.cc \
+ primitives.cc \
+ quad.cc \
+ tags.cc \
+ triangle.cc \
+ vertexarray.cc
+
+libmodel_la_DEPENDENCIES = \
+ $(top_builddir)/src/auxiliary/libauxiliary.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/sys/libsys.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la
+libmodel_la_LDFLAGS = -avoid-version -no-undefined