Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2010-10-17 17:19:03 +0000
committerStijn Buys <ingar@osirion.org>2010-10-17 17:19:03 +0000
commitd6e4c4e7c2b1e28961f1dfe2f25ef96ced60b21b (patch)
tree63744dff093a8b23f65d9c68b922b678805647d9 /src/render/Makefile.am
parentea6e6bb769d713ac55114c1940626f13e384ebed (diff)
core bullet physics support,
initial vstrafe support
Diffstat (limited to 'src/render/Makefile.am')
-rw-r--r--src/render/Makefile.am45
1 files changed, 39 insertions, 6 deletions
diff --git a/src/render/Makefile.am b/src/render/Makefile.am
index 4636250..4389805 100644
--- a/src/render/Makefile.am
+++ b/src/render/Makefile.am
@@ -8,10 +8,43 @@ noinst_LTLIBRARIES = librender.la
endif
librender_la_LDFLAGS = -avoid-version -no-undefined @GL_LIBS@
+
librender_la_LIBADD = $(top_builddir)/src/math/libmath.la
-librender_la_SOURCES = camera.cc draw.cc dust.cc gl.cc image.cc jpgfile.cc \
- particles.cc pngfile.cc render.cc renderext.cc screenshot.cc sky.cc \
- state.cc text.cc textures.cc tgafile.cc
-noinst_HEADERS = camera.h draw.h dust.h gl.h image.h jpgfile.h \
- particles.h pngfile.h render.h renderext.h screenshot.h sky.h \
- state.h text.h textures.h tgafile.h
+
+librender_la_SOURCES = \
+ camera.cc \
+ debugdrawer.cc \
+ draw.cc \
+ dust.cc \
+ gl.cc \
+ image.cc \
+ jpgfile.cc \
+ particles.cc \
+ pngfile.cc \
+ render.cc \
+ renderext.cc \
+ screenshot.cc \
+ sky.cc \
+ state.cc \
+ text.cc \
+ textures.cc \
+ tgafile.cc
+
+noinst_HEADERS = \
+ camera.h \
+ debugdrawer.h \
+ draw.h \
+ dust.h \
+ gl.h \
+ image.h \
+ jpgfile.h \
+ particles.h \
+ pngfile.h \
+ render.h \
+ renderext.h \
+ screenshot.h \
+ sky.h \
+ state.h \
+ text.h \
+ textures.h \
+ tgafile.h