Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-10-05 19:03:25 +0000
committerStijn Buys <ingar@osirion.org>2008-10-05 19:03:25 +0000
commitda9beb729c58ca2d91f67ab85a6728b628c27cf2 (patch)
tree96fd5df00a2431f40f515aa9fdf722377a0b6079 /src/ui/Makefile.am
parent381c729e777b50771626703e60b422aafc791513 (diff)
user interface library
Diffstat (limited to 'src/ui/Makefile.am')
-rw-r--r--src/ui/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/ui/Makefile.am b/src/ui/Makefile.am
new file mode 100644
index 0000000..c64860a
--- /dev/null
+++ b/src/ui/Makefile.am
@@ -0,0 +1,9 @@
+INCLUDES = -I$(top_srcdir)/src
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libui.la
+noinst_HEADERS = button.h label.h menu.h palette.h ui.h widget.h window.h
+
+libui_la_SOURCES = button.cc label.cc menu.cc palette.cc ui.cc widget.cc \
+ window.cc
+libui_la_LDFLAGS = -avoid-version -no-undefined