Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index de8e2dd..e008db6 100644
--- a/configure.in
+++ b/configure.in
@@ -144,13 +144,22 @@ if test "x${with_ncurses}" != "xno"; then
CPPFLAGS="$CPPFLAGS $CURSES_CFLAGS"
AC_CHECK_HEADER(ncurses.h,
- HAVE_CURSES=yes
- AC_DEFINE(HAVE_CURSES, 1, [Define this if you have ncurses])
+ HAVE_CURSES=ncurses
+ AC_DEFINE(HAVE_CURSES, 1, [Define this if you have the curses library])
CURSES_LIBS="$NCURSES_LIBS -lncurses",
HAVE_CURSES=no
)
- CPPFLAGS="$save_CPPFLAGS"
+ if test "x${HAVE_CURSES}" = "xno"; then
+ AC_CHECK_HEADER(curses.h,
+ HAVE_CURSES=pdcurses
+ AC_DEFINE(HAVE_CURSES, 1, [Define this if you have the curses library])
+ CURSES_LIBS="$NCURSES_LIBS -lpdcurses",
+ HAVE_CURSES=no
+ )
+ fi
+
+ CPPFLAGS="$save_CPPFLAGS"
fi
AC_SUBST(CURSES_CFLAGS)
AC_SUBST(CURSES_LIBS)
@@ -302,7 +311,7 @@ Configuration summary:
platform ........... $host
flags .............. $CXXFLAGS
libraries .......... $HOST_LIBS $LIBJPG_LIBS $LIBPNG_LIBS
- ncurses ............ $HAVE_CURSES
+ curses ............. $HAVE_CURSES
build client ....... $BUILD_CLIENT
opengl ............. $GL_LIBS
openal ............. $AL_LIBS