Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index 56a2cc2..629102f 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -1,11 +1,17 @@
METASOURCES = AUTO
INCLUDES = -I$(top_srcdir)/src
+if BUILD_DEDICATED
+noinst_LTLIBRARIES =
+else
+noinst_LTLIBRARIES = libclient.la
+endif
+
libclient_la_SOURCES = chat.cc client.cc console.cc hud.cc input.cc key.cc \
keyboard.cc radar.cc video.cc view.cc
libclient_la_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
libclient_la_LDFLAGS = -avoid-version -no-undefined $(GL_LIBS) $(LIBSDL_LIBS)
-noinst_LTLIBRARIES = libclient.la
+
noinst_HEADERS = chat.h client.h console.h input.h key.h keyboard.h radar.h \
video.h view.h
libclient_la_LIBADD = $(top_builddir)/src/render/librender.la \