Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/filesystem/Makefile.am')
-rw-r--r--src/filesystem/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/filesystem/Makefile.am b/src/filesystem/Makefile.am
new file mode 100644
index 0000000..9ef09bd
--- /dev/null
+++ b/src/filesystem/Makefile.am
@@ -0,0 +1,10 @@
+METASOURCES = AUTO
+
+libfilesystem_la_SOURCES = file.cc filesystem.cc inifile.cc path.cc
+libfilesystem_la_LDFLAGS = -avoid-version -no-undefined
+libfilesystem_la_LIBADD = $(top_builddir)/src/common/libcommon.la
+
+noinst_LTLIBRARIES = libfilesystem.la
+noinst_HEADERS = file.h filesystem.h path.h
+
+INCLUDES = -I$(top_srcdir)/src