Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/game/Makefile.am')
-rw-r--r--src/game/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/game/Makefile.am b/src/game/Makefile.am
index ff591eb..91838e6 100644
--- a/src/game/Makefile.am
+++ b/src/game/Makefile.am
@@ -1,10 +1,10 @@
-INCLUDES = -I$(top_srcdir)/src
+INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
METASOURCES = AUTO
libgame_la_LDFLAGS = -avoid-version
-libgame_la_SOURCES = game.cc jumppoint.cc navpoint.cc planet.cc racetrack.cc \
- ship.cc shipmodel.cc star.cc
+libgame_la_SOURCES = game.cc
noinst_LTLIBRARIES = libgame.la
-noinst_HEADERS = game.h navpoint.h planet.h racetrack.h ship.h shipmodel.h \
- star.h jumppoint.h
+noinst_HEADERS = game.h
+SUBDIRS = base intro
+libgame_la_LIBADD = $(top_builddir)/src/game/base/libbase.la