Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/game/base/Makefile.am')
-rw-r--r--src/game/base/Makefile.am30
1 files changed, 26 insertions, 4 deletions
diff --git a/src/game/base/Makefile.am b/src/game/base/Makefile.am
index 2dcea93..6391468 100644
--- a/src/game/base/Makefile.am
+++ b/src/game/base/Makefile.am
@@ -2,7 +2,29 @@ INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
METASOURCES = AUTO
libbase_la_LDFLAGS = -avoid-version
noinst_LTLIBRARIES = libbase.la
-libbase_la_SOURCES = cargo.cc cargopod.cc game.cc jumppoint.cc navpoint.cc planet.cc \
- racetrack.cc ship.cc shipmodel.cc star.cc station.cc
-noinst_HEADERS = cargo.h cargopod.h game.h jumppoint.h navpoint.h planet.h \
- racetrack.h ship.h shipmodel.h star.h station.h
+libbase_la_SOURCES = \
+ cargo.cc \
+ cargopod.cc \
+ faction.cc \
+ game.cc \
+ jumppoint.cc \
+ navpoint.cc \
+ planet.cc \
+ racetrack.cc \
+ ship.cc \
+ shipmodel.cc \
+ star.cc \
+ station.cc
+noinst_HEADERS = \
+ cargo.h \
+ cargopod.h \
+ game.h \
+ faction.h \
+ jumppoint.h \
+ navpoint.h \
+ planet.h \
+ racetrack.h \
+ ship.h \
+ shipmodel.h \
+ star.h \
+ station.h