Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/game/base/Makefile.am')
-rw-r--r--src/game/base/Makefile.am44
1 files changed, 28 insertions, 16 deletions
diff --git a/src/game/base/Makefile.am b/src/game/base/Makefile.am
index bb0d967..a64f73f 100644
--- a/src/game/base/Makefile.am
+++ b/src/game/base/Makefile.am
@@ -1,21 +1,8 @@
-INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
METASOURCES = AUTO
-libbase_la_LDFLAGS = -avoid-version
+INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
+
noinst_LTLIBRARIES = libbase.la
-libbase_la_SOURCES = \
- cargo.cc \
- cargopod.cc \
- faction.cc \
- game.cc \
- jumppoint.cc \
- navpoint.cc \
- planet.cc \
- racetrack.cc \
- ship.cc \
- shipmodel.cc \
- star.cc \
- station.cc \
- template.cc
+
noinst_HEADERS = \
cargo.h \
cargopod.h \
@@ -30,3 +17,28 @@ noinst_HEADERS = \
star.h \
station.h \
template.h
+
+libbase_la_SOURCES = \
+ cargo.cc \
+ cargopod.cc \
+ faction.cc \
+ game.cc \
+ jumppoint.cc \
+ navpoint.cc \
+ planet.cc \
+ racetrack.cc \
+ ship.cc \
+ shipmodel.cc \
+ star.cc \
+ station.cc \
+ template.cc
+
+libbase_la_LDFLAGS = -avoid-version -no-undefined
+
+libbase_la_DEPENDENCIES = \
+ $(top_builddir)/src/auxiliary/libauxiliary.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/sys/libsys.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la \
+ $(top_builddir)/src/model/libmodel.la \
+ $(top_builddir)/src/core/libcore.la