Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/game/intro/Makefile.am')
-rw-r--r--src/game/intro/Makefile.am24
1 files changed, 20 insertions, 4 deletions
diff --git a/src/game/intro/Makefile.am b/src/game/intro/Makefile.am
index eeb6f9d..a9d09b9 100644
--- a/src/game/intro/Makefile.am
+++ b/src/game/intro/Makefile.am
@@ -1,6 +1,22 @@
-INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
METASOURCES = AUTO
-libintro_la_LDFLAGS = -avoid-version
+INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/game
+
noinst_LTLIBRARIES = libintro.la
-libintro_la_SOURCES = convoy.cc intro.cc
-noinst_HEADERS = convoy.h intro.h
+
+noinst_HEADERS = \
+ convoy.h \
+ intro.h
+
+libintro_la_SOURCES = \
+ convoy.cc \
+ intro.cc
+
+libintro_la_DEPENDENCIES = \
+ $(top_builddir)/src/auxiliary/libauxiliary.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/sys/libsys.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la \
+ $(top_builddir)/src/model/libmodel.la \
+ $(top_builddir)/src/core/libcore.la
+
+libintro_la_LDFLAGS = -avoid-version -no-undefined