Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/ui/Makefile.am')
-rw-r--r--src/ui/Makefile.am66
1 files changed, 56 insertions, 10 deletions
diff --git a/src/ui/Makefile.am b/src/ui/Makefile.am
index a98e964..36a1ac1 100644
--- a/src/ui/Makefile.am
+++ b/src/ui/Makefile.am
@@ -1,5 +1,6 @@
-INCLUDES = -I$(top_srcdir)/src
METASOURCES = AUTO
+INCLUDES = -I$(top_srcdir)/src
+
if BUILD_DEDICATED
noinst_LTLIBRARIES =
@@ -7,15 +8,60 @@ else
noinst_LTLIBRARIES = libui.la
endif
-noinst_HEADERS = bitmap.h button.h console.h container.h definitions.h font.h \
- iconbutton.h inputbox.h label.h listitem.h listview.h \
- menu.h modelview.h paint.h palette.h plaintext.h scrollpane.h \
- slider.h toolbar.h ui.h widget.h window.h
+noinst_HEADERS = \
+ bitmap.h \
+ button.h \
+ console.h \
+ container.h \
+ definitions.h \
+ font.h \
+ iconbutton.h \
+ inputbox.h \
+ label.h \
+ listitem.h \
+ listview.h \
+ menu.h \
+ modelview.h \
+ paint.h \
+ palette.h \
+ plaintext.h \
+ scrollpane.h \
+ slider.h \
+ toolbar.h \
+ ui.h \
+ widget.h \
+ window.h
-libui_la_SOURCES = bitmap.cc button.cc console.cc container.cc font.cc \
- iconbutton.cc inputbox.cc label.cc listitem.cc listview.cc \
- menu.cc modelview.cc paint.cc palette.cc plaintext.cc scrollpane.cc \
- slider.cc toolbar.cc ui.cc widget.cc window.cc
+libui_la_SOURCES = \
+ bitmap.cc \
+ button.cc \
+ console.cc \
+ container.cc \
+ font.cc \
+ iconbutton.cc \
+ inputbox.cc \
+ label.cc \
+ listitem.cc \
+ listview.cc \
+ menu.cc \
+ modelview.cc \
+ paint.cc \
+ palette.cc \
+ plaintext.cc \
+ scrollpane.cc \
+ slider.cc \
+ toolbar.cc \
+ ui.cc \
+ widget.cc \
+ window.cc
-libui_la_LDFLAGS = -avoid-version -no-undefined
+libui_la_DEPENDENCIES = \
+ $(top_builddir)/src/auxiliary/libauxiliary.la \
+ $(top_builddir)/src/math/libmath.la \
+ $(top_builddir)/src/sys/libsys.la \
+ $(top_builddir)/src/filesystem/libfilesystem.la \
+ $(top_builddir)/src/model/libmodel.la \
+ $(top_builddir)/src/core/libcore.la \
+ $(top_builddir)/src/render/librender.la
+libui_la_LDFLAGS = -avoid-version -no-undefined