Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2007-10-20 10:02:51 +0000
committerStijn Buys <ingar@osirion.org>2007-10-20 10:02:51 +0000
commit3866f2b33313d891347f454537843befd295b78f (patch)
treeba748f4bf021605cc8e1488e7e14a4085f81a9ae /src/client/Makefile.am
Initial import.
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
new file mode 100644
index 0000000..f234f49
--- /dev/null
+++ b/src/client/Makefile.am
@@ -0,0 +1,12 @@
+
+METASOURCES = AUTO
+bin_PROGRAMS = osirion
+osirion_LDADD = $(top_builddir)/src/common/libcommon.la \
+ $(top_builddir)/src/game/libgame.la $(top_builddir)/src/gl/libosiriongl.la -lSDL
+osirion_SOURCES = camera.cc camera.h input.cc input.h main.cc video.cc video.h \
+ view.cc view.h shipdrawer.cc shipdrawer.h stardrawer.cc stardrawer.h
+
+
+
+INCLUDES = -I$(top_srcdir)/src
+osirion_LDFLAGS = -L/usr/X11/lib64