Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2010-02-20 20:11:42 +0000
committerStijn Buys <ingar@osirion.org>2010-02-20 20:11:42 +0000
commit4fbce883cdf6b39e7e6f1c4840483062e6d60757 (patch)
tree77f96ef48cc5901fc237289b3a6ea0fdc4d372eb /src/client/Makefile.am
parentb6cefbb4c030e86865352e6ad941782121fc5a93 (diff)
Reverting accidental commit
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
index d4d4d4e..a90bfdb 100644
--- a/src/client/Makefile.am
+++ b/src/client/Makefile.am
@@ -7,16 +7,19 @@ else
noinst_LTLIBRARIES = libclient.la
endif
-libclient_la_SOURCES = action.cc buymenu.cc chat.cc chatbox.cc chathistory.cc chatwindow.cc client.cc clientext.cc \
+libclient_la_SOURCES = action.cc buymenu.cc chat.cc client.cc clientext.cc \
entitymenu.cc hud.cc infowidget.cc input.cc joystick.cc key.cc keyboard.cc map.cc \
notifications.cc playerview.cc soundext.cc targeticonbutton.cc targets.cc trademenu.cc \
video.cc worldview.cc
+
libclient_la_CFLAGS = $(LIBSDL_CFLAGS) $(GL_CFLAGS)
+
libclient_la_LDFLAGS = -avoid-version -no-undefined $(GL_LIBS) $(LIBSDL_LIBS)
-noinst_HEADERS = action.h chat.h chatbox.h chathistory.h chatwindow.h client.h clientext.h hud.h entitymenu.h \
+noinst_HEADERS = action.h chat.h client.h clientext.h hud.h entitymenu.h \
input.h joystick.h key.h keyboard.h map.h notifications.h soundext.h \
targets.h video.h infowidget.h playerview.h worldview.h trademenu.h buymenu.h \
targeticonbutton.h
+
libclient_la_LIBADD = $(top_builddir)/src/core/libcore.la $(top_builddir)/src/audio/libaudio.la \
$(top_builddir)/src/render/librender.la $(top_builddir)/src/ui/libui.la