Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-01-30 17:36:03 +0000
committerStijn Buys <ingar@osirion.org>2008-01-30 17:36:03 +0000
commitd584d29ac49182130d643c9221047e0acb5cfa01 (patch)
tree06f23cb1cae0a1945e88ea7f19ad80394cb35d6b /src/gl/Makefile.am
parentbac8343bbc9f1e4cf97a561c732054539f21f03d (diff)
accomodate the new modules
Diffstat (limited to 'src/gl/Makefile.am')
-rw-r--r--src/gl/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/gl/Makefile.am b/src/gl/Makefile.am
index 291565d..7c1445e 100644
--- a/src/gl/Makefile.am
+++ b/src/gl/Makefile.am
@@ -1,9 +1,10 @@
-
METASOURCES = AUTO
+INCLUDES = -I$(top_srcdir)/src
-libosiriongl_la_LDFLAGS = -avoid-version -no-undefined
-noinst_LTLIBRARIES = libosiriongl.la
+libgl_la_SOURCES = box.cc sphere.cc gllib.cc
+libgl_la_LDFLAGS = -avoid-version -no-undefined @GL_LIBS@
+libgl_la_CXXFLAGS = @GL_CFLAGS@
+
+noinst_LTLIBRARIES = libgl.la
+noinst_HEADERS = box.h gllib.h sphere.h
-INCLUDES = -I$(top_srcdir)/src
-libosiriongl_la_SOURCES = box.cc sphere.cc osiriongl.cc
-noinst_HEADERS = box.h osiriongl.h sphere.h