Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/gl/Makefile.am')
-rw-r--r--src/gl/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/gl/Makefile.am b/src/gl/Makefile.am
index 291565d..7c1445e 100644
--- a/src/gl/Makefile.am
+++ b/src/gl/Makefile.am
@@ -1,9 +1,10 @@
-
METASOURCES = AUTO
+INCLUDES = -I$(top_srcdir)/src
-libosiriongl_la_LDFLAGS = -avoid-version -no-undefined
-noinst_LTLIBRARIES = libosiriongl.la
+libgl_la_SOURCES = box.cc sphere.cc gllib.cc
+libgl_la_LDFLAGS = -avoid-version -no-undefined @GL_LIBS@
+libgl_la_CXXFLAGS = @GL_CFLAGS@
+
+noinst_LTLIBRARIES = libgl.la
+noinst_HEADERS = box.h gllib.h sphere.h
-INCLUDES = -I$(top_srcdir)/src
-libosiriongl_la_SOURCES = box.cc sphere.cc osiriongl.cc
-noinst_HEADERS = box.h osiriongl.h sphere.h