Project::OSiRiON - Git repositories
Project::OSiRiON
News . About . Screenshots . Downloads . Forum . Wiki . Tracker . Git
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2008-05-04 22:30:49 +0000
committerStijn Buys <ingar@osirion.org>2008-05-04 22:30:49 +0000
commit7218e3bd4616d4706090ec47d72845a2bb89c6a3 (patch)
treecbf3fdb0dddf573edff89b50af22e8a84690cf00 /src/model/Makefile.am
parent33e45d8052b385aa8b1fce68122c8d11f50e7e42 (diff)
split map reading from models
Diffstat (limited to 'src/model/Makefile.am')
-rw-r--r--src/model/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/model/Makefile.am b/src/model/Makefile.am
index 5df1fd7..25985bb 100644
--- a/src/model/Makefile.am
+++ b/src/model/Makefile.am
@@ -1,9 +1,11 @@
METASOURCES = AUTO
-libmodel_la_SOURCES = engine.cc light.cc model.cc vertexarray.cc
+libmodel_la_SOURCES = engine.cc light.cc map.cc mapfile.cc model.cc plane.cc \
+ tirangle.cc vertexarray.cc
libmodel_la_LDFLAGS = -avoid-version -no-undefined -lm
noinst_LTLIBRARIES = libmodel.la
-noinst_HEADERS = engine.h light.h model.h vertexarray.h
+noinst_HEADERS = engine.h light.h map.h mapfile.h model.h plane.h triangle.h \
+ vertexarray.h
INCLUDES = -I$(top_srcdir)/src